summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine-a <sanine.not@pm.me>2020-05-20 18:10:16 -0500
committersanine-a <sanine.not@pm.me>2020-05-20 18:10:16 -0500
commit447c3de585cca51013b17017d968e3aee53f5c87 (patch)
treea728c4de651c4df82bc09ecc60672ab4798b4491 /CMakeLists.txt
an initial commit
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..d566887
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,15 @@
+cmake_minimum_required(VERSION 3.2)
+project(honey_engine_demo)
+
+find_package(OpenGL REQUIRED)
+
+add_executable(honey_engine_demo demo.c)
+
+add_library(honey_shader "src/shader.c")
+add_library(glad "src/glad.c")
+add_library(stb_image "src/stb_image.c")
+
+set(LIBRARIES honey_shader glfw GL dl m glad stb_image)
+target_link_libraries(honey_engine_demo ${LIBRARIES})
+
+