summaryrefslogtreecommitdiff
path: root/libs/lua-5.1.5/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-18 20:52:26 -0500
committersanine <sanine.not@pm.me>2022-08-18 20:52:26 -0500
commitb8147afcc5bfbeb5fad62e4f68f1b88fc6c60d96 (patch)
tree8e5b63933b05a54bc2e74160fd2d53354a23f3d4 /libs/lua-5.1.5/CMakeLists.txt
parentde97d73a33ee3c1e2fe325b0cff90f079519bb36 (diff)
add lua-5.1.5 files
Diffstat (limited to 'libs/lua-5.1.5/CMakeLists.txt')
-rw-r--r--libs/lua-5.1.5/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/libs/lua-5.1.5/CMakeLists.txt b/libs/lua-5.1.5/CMakeLists.txt
new file mode 100644
index 0000000..4004db2
--- /dev/null
+++ b/libs/lua-5.1.5/CMakeLists.txt
@@ -0,0 +1,34 @@
+cmake_minimum_required(VERSION 3.2)
+project(lua5.1)
+
+set(LUA_ROOT ${lua5.1_SOURCE_DIR}/src)
+add_library(lua5.1
+ ${LUA_ROOT}/lapi.c
+ ${LUA_ROOT}/lcode.c
+ ${LUA_ROOT}/ldebug.c
+ ${LUA_ROOT}/ldo.c
+ ${LUA_ROOT}/ldump.c
+ ${LUA_ROOT}/lfunc.c
+ ${LUA_ROOT}/lgc.c
+ ${LUA_ROOT}/llex.c
+ ${LUA_ROOT}/lmem.c
+ ${LUA_ROOT}/lobject.c
+ ${LUA_ROOT}/lopcodes.c
+ ${LUA_ROOT}/lparser.c
+ ${LUA_ROOT}/lstate.c
+ ${LUA_ROOT}/lstring.c
+ ${LUA_ROOT}/ltable.c
+ ${LUA_ROOT}/ltm.c
+ ${LUA_ROOT}/lundump.c
+ ${LUA_ROOT}/lvm.c
+ ${LUA_ROOT}/lzio.c
+ ${LUA_ROOT}/lauxlib.c
+ ${LUA_ROOT}/lbaselib.c
+ ${LUA_ROOT}/ldblib.c
+ ${LUA_ROOT}/liolib.c
+ ${LUA_ROOT}/lmathlib.c
+ ${LUA_ROOT}/loslib.c
+ ${LUA_ROOT}/ltablib.c
+ ${LUA_ROOT}/lstrlib.c
+ ${LUA_ROOT}/loadlib.c
+ ${LUA_ROOT}/linit.c)