summaryrefslogtreecommitdiff
path: root/libs/ode-0.16.1/tests/Makefile.am
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-10-01 20:59:36 -0500
committersanine <sanine.not@pm.me>2022-10-01 20:59:36 -0500
commitc5fc66ee58f2c60f2d226868bb1cf5b91badaf53 (patch)
tree277dd280daf10bf77013236b8edfa5f88708c7e0 /libs/ode-0.16.1/tests/Makefile.am
parent1cf9cc3408af7008451f9133fb95af66a9697d15 (diff)
add ode
Diffstat (limited to 'libs/ode-0.16.1/tests/Makefile.am')
-rw-r--r--libs/ode-0.16.1/tests/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/libs/ode-0.16.1/tests/Makefile.am b/libs/ode-0.16.1/tests/Makefile.am
new file mode 100644
index 0000000..7ed8620
--- /dev/null
+++ b/libs/ode-0.16.1/tests/Makefile.am
@@ -0,0 +1,30 @@
+SUBDIRS = joints UnitTest++
+
+AM_CPPFLAGS = -I$(srcdir)/UnitTest++/src \
+ -I$(top_srcdir)/include \
+ -I$(top_builddir)/include \
+ -I$(top_srcdir)/ode/src
+
+if GIMPACT
+ AM_CPPFLAGS += -DdTRIMESH_ENABLED -DdTRIMESH_GIMPACT
+endif
+if OPCODE
+ AM_CPPFLAGS += -DdTRIMESH_ENABLED -DdTRIMESH_OPCODE
+endif
+
+
+check_PROGRAMS = tests
+
+TESTS = tests
+
+tests_SOURCES = \
+ collision.cpp \
+ friction.cpp \
+ joint.cpp \
+ main.cpp \
+ odemath.cpp
+
+tests_LDADD = \
+ $(top_builddir)/ode/src/libode.la \
+ joints/*.o \
+ UnitTest++/src/libunittestpp.la