summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d566887..9ae826f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,15 +1,19 @@
cmake_minimum_required(VERSION 3.2)
project(honey_engine_demo)
+#set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
+
find_package(OpenGL REQUIRED)
add_executable(honey_engine_demo demo.c)
-add_library(honey_shader "src/shader.c")
-add_library(glad "src/glad.c")
-add_library(stb_image "src/stb_image.c")
+set(CMAKE_C_FLAGS "-g")
+
+add_library(honey src/honey_setup.c src/shader.c src/mesh.c)
+add_library(glad src/glad.c)
+add_library(stb_image src/stb_image.c)
-set(LIBRARIES honey_shader glfw GL dl m glad stb_image)
+set(LIBRARIES honey glfw GL dl m glad stb_image)
target_link_libraries(honey_engine_demo ${LIBRARIES})