summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ef38dec..a29a6f1 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -20,11 +20,17 @@ add_library(glad ${SRC_ROOT}/gl/glad/glad.c)
# add_library(stb_image src/stb_image/stb_image.c)
add_subdirectory(${LIB_ROOT}/assimp)
add_subdirectory(${LIB_ROOT}/honeysuckle)
+add_subdirectory(${LIB_ROOT}/cglm)
set(HONEY_LIB_FILES
${SRC_ROOT}/logging/logging.c
+
${SRC_ROOT}/gl/honey_window.c
+ ${SRC_ROOT}/gl/honey_shader.c
+ ${SRC_ROOT}/gl/honey_gl_error.c
+ ${SRC_ROOT}/gl/honey_gl.c
+
${SRC_ROOT}/options/honey_options.c
)