summaryrefslogtreecommitdiff
path: root/libs/glfw-3.3.8/docs/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/glfw-3.3.8/docs/CMakeLists.txt')
-rw-r--r--libs/glfw-3.3.8/docs/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/libs/glfw-3.3.8/docs/CMakeLists.txt b/libs/glfw-3.3.8/docs/CMakeLists.txt
new file mode 100644
index 0000000..2347858
--- /dev/null
+++ b/libs/glfw-3.3.8/docs/CMakeLists.txt
@@ -0,0 +1,34 @@
+
+# NOTE: The order of this list determines the order of items in the Guides
+# (i.e. Pages) list in the generated documentation
+set(GLFW_DOXYGEN_SOURCES
+ "include/GLFW/glfw3.h"
+ "include/GLFW/glfw3native.h"
+ "docs/main.dox"
+ "docs/news.dox"
+ "docs/quick.dox"
+ "docs/moving.dox"
+ "docs/compile.dox"
+ "docs/build.dox"
+ "docs/intro.dox"
+ "docs/context.dox"
+ "docs/monitor.dox"
+ "docs/window.dox"
+ "docs/input.dox"
+ "docs/vulkan.dox"
+ "docs/compat.dox"
+ "docs/internal.dox")
+
+# Format the source list into a Doxyfile INPUT value that Doxygen can parse
+foreach(path IN LISTS GLFW_DOXYGEN_SOURCES)
+ set(GLFW_DOXYGEN_INPUT "${GLFW_DOXYGEN_INPUT} \\\n\"${GLFW_SOURCE_DIR}/${path}\"")
+endforeach()
+
+configure_file(Doxyfile.in Doxyfile @ONLY)
+
+add_custom_target(docs ALL "${DOXYGEN_EXECUTABLE}"
+ WORKING_DIRECTORY "${GLFW_BINARY_DIR}/docs"
+ COMMENT "Generating HTML documentation" VERBATIM)
+
+set_target_properties(docs PROPERTIES FOLDER "GLFW3")
+