summaryrefslogtreecommitdiff
path: root/libs/ode-0.16.1/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libs/ode-0.16.1/Makefile.am')
-rw-r--r--libs/ode-0.16.1/Makefile.am48
1 files changed, 48 insertions, 0 deletions
diff --git a/libs/ode-0.16.1/Makefile.am b/libs/ode-0.16.1/Makefile.am
new file mode 100644
index 0000000..c786f5c
--- /dev/null
+++ b/libs/ode-0.16.1/Makefile.am
@@ -0,0 +1,48 @@
+AUTOMAKE_OPTIONS = foreign
+ACLOCAL_AMFLAGS = -I m4 --install
+
+if ENABLE_OU
+OU_DIR = ou
+endif
+
+if LIBCCD
+if LIBCCD_INTERNAL
+LIBCCD_DIR = libccd
+endif
+endif
+
+if ENABLE_DEMOS
+DRAWSTUFF_DIR = drawstuff
+endif
+
+if GIMPACT
+GIMPACT_DIR = GIMPACT
+endif
+
+if OPCODE
+OPCODE_DIR = OPCODE
+endif
+
+SUBDIRS = include \
+ $(DRAWSTUFF_DIR) \
+ $(GIMPACT_DIR) \
+ $(OPCODE_DIR) \
+ $(OU_DIR) \
+ $(LIBCCD_DIR) \
+ ode \
+ tests
+
+bin_SCRIPTS = ode-config
+
+# Utility rule for making a release
+release: dist-gzip dist-bzip2
+ @echo Created release packages for ${PACKAGE}-${VERSION}.
+
+EXTRA_DIST = bootstrap build tools \
+ CHANGELOG.txt COPYING INSTALL.txt CSR.txt README.md \
+ LICENSE.TXT LICENSE-BSD.TXT \
+ bindings \
+ CMakeLists.txt ode-config.cmake.in config.h.cmake.in cmake
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = ode.pc