summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-12-10 19:12:31 -0600
committersanine <sanine.not@pm.me>2022-12-10 19:12:31 -0600
commit7c47f23ee92afa07c748700f1de22fd8b8ccf967 (patch)
tree4387add23b932b74c237128c579c4c2c9005262a /CMakeLists.txt
parent8bc49efb970ac44f17f6076bb16f1d0e712bd750 (diff)
refactor: remove node.* and util.* and move 3rdparty libs into separate directory
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f493c77..de4fd2c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,7 @@ project(kalmia)
option(KALMIA_BUILD_TESTS "Build the tests" ON)
add_library(kalmia STATIC)
-target_include_directories(kalmia PUBLIC include)
+target_include_directories(kalmia PUBLIC include 3rdparty 3rdparty/ezxml)
if (UNIX)
set_target_properties(
kalmia PROPERTIES
@@ -24,3 +24,4 @@ if (KALMIA_BUILD_TESTS)
endif()
add_subdirectory(${CMAKE_CURRENT_LIST_DIR}/src)
+add_subdirectory(${CMAKE_CURRENT_LIST_DIR}/3rdparty/ezxml)