summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 12 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de4fd2c..bf4279e 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,6 +2,7 @@ cmake_minimum_required(VERSION 3.13)
project(kalmia)
option(KALMIA_BUILD_TESTS "Build the tests" ON)
+option(KALMIA_BUILD_EXAMPLE "Build the example" ON)
add_library(kalmia STATIC)
target_include_directories(kalmia PUBLIC include 3rdparty 3rdparty/ezxml)
@@ -23,5 +24,14 @@ if (KALMIA_BUILD_TESTS)
endif()
endif()
-add_subdirectory(${CMAKE_CURRENT_LIST_DIR}/src)
-add_subdirectory(${CMAKE_CURRENT_LIST_DIR}/3rdparty/ezxml)
+# if (KALMIA_BUILD_EXAMPLE)
+# add_executable(kalmia-example)
+# target_link_libraries(kalmia-example kalmia)
+# if (UNIX)
+# target_link_libraries(kalmia-example m)
+# endif()
+# add_subdirectory(${CMAKE_CURRENT_LIST_DIR}/example)
+# endif()
+
+add_subdirectory(src)
+add_subdirectory(3rdparty/ezxml)