summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..bf3ca8a
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,21 @@
+cmake_minimum_required(VERSION 3.13)
+project(kalmia)
+
+option(KALMIA_BUILD_TESTS "Build the tests" ON)
+
+add_library(kalmia STATIC)
+target_include_directories(kalmia PUBLIC include)
+if (UNIX)
+ set_target_properties(
+ kalmia PROPERTIES
+ C_STANDARD 90
+ CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic"
+ )
+endif()
+
+if (KALMIA_BUILD_TESTS)
+ add_executable(kalmia-tests)
+ target_link_libraries(kalmia-tests kalmia)
+endif()
+
+add_subdirectory(${CMAKE_CURRENT_LIST_DIR}/src)