summaryrefslogtreecommitdiff
path: root/src/geometry/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/geometry/CMakeLists.txt')
-rw-r--r--src/geometry/CMakeLists.txt10
1 files changed, 10 insertions, 0 deletions
diff --git a/src/geometry/CMakeLists.txt b/src/geometry/CMakeLists.txt
new file mode 100644
index 0000000..006fc27
--- /dev/null
+++ b/src/geometry/CMakeLists.txt
@@ -0,0 +1,10 @@
+project(kalmia)
+
+target_sources(kalmia PUBLIC geometry.c)
+
+if (KALMIA_BUILD_TESTS)
+ target_sources(
+ kalmia-tests PUBLIC
+ geometry.test.c
+ )
+endif()