summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine-a <sanine.not@pm.me>2021-12-21 11:00:32 -0600
committersanine-a <sanine.not@pm.me>2021-12-21 11:00:32 -0600
commitb712a7ac4c6a7a8bb1d81d0adad8f98084b4d2fe (patch)
treec7c1a3add4eea07f3580e9c9c2fa9d9a8a088a8a /CMakeLists.txt
parent98ab574f51a223bbd53052ded32dce6aebca9298 (diff)
refactor: move lily-test.h into root directory and move src/ -> tests/
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 379417a..c856cb4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,7 +4,8 @@ project(
VERSION 0.1.0
DESCRIPTION "A super-simple single-header C test framework")
-add_executable(lily-metatest ${CMAKE_SOURCE_DIR}/src/test.c)
+include_directories(${CMAKE_SOURCE_DIR})
+add_executable(lily-metatest ${CMAKE_SOURCE_DIR}/tests/test.c)
set_target_properties(lily-metatest PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")