summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2021-12-21 20:58:51 -0600
committersanine <sanine.not@pm.me>2021-12-21 20:58:51 -0600
commit1e3ca08048542a29d04ecc2c1dbc0e5ba8421c27 (patch)
tree95e5864e42c2407bad18fc43818119e60c123f85 /CMakeLists.txt
parentb712a7ac4c6a7a8bb1d81d0adad8f98084b4d2fe (diff)
strip things down in preparation for refactor
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c856cb4..f7acc8a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,10 @@ project(
DESCRIPTION "A super-simple single-header C test framework")
include_directories(${CMAKE_SOURCE_DIR})
-add_executable(lily-metatest ${CMAKE_SOURCE_DIR}/tests/test.c)
+set (TEST_SRC ${CMAKE_SOURCE_DIR}/tests)
+add_executable(lily-metatest
+ ${TEST_SRC}/main.c
+ ${TEST_SRC}/helpers.c)
set_target_properties(lily-metatest PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")