summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index c856cb4..f7acc8a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,7 +5,10 @@ project(
DESCRIPTION "A super-simple single-header C test framework")
include_directories(${CMAKE_SOURCE_DIR})
-add_executable(lily-metatest ${CMAKE_SOURCE_DIR}/tests/test.c)
+set (TEST_SRC ${CMAKE_SOURCE_DIR}/tests)
+add_executable(lily-metatest
+ ${TEST_SRC}/main.c
+ ${TEST_SRC}/helpers.c)
set_target_properties(lily-metatest PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")