summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-26 12:42:30 -0500
committersanine <sanine.not@pm.me>2022-08-26 12:42:30 -0500
commitbde3e4f1bb7b8f8abca0884a7d994ee1c17a66b1 (patch)
tree825ff3669a38ec247bcc9b575a4a4ceb81534d35 /src/CMakeLists.txt
parent8ec3f8e82acd70410515550fd1790ee5827aafdb (diff)
refactor: move mossrose.h to include/ dir
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
new file mode 100644
index 0000000..069d00a
--- /dev/null
+++ b/src/CMakeLists.txt
@@ -0,0 +1,7 @@
+project(mossrose)
+
+target_sources(mossrose PUBLIC
+ ${CMAKE_CURRENT_LIST_DIR}/mossrose.c
+ ${CMAKE_CURRENT_LIST_DIR}/mutex.c
+ ${CMAKE_CURRENT_LIST_DIR}/channel.c
+)