summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-28 11:25:44 -0500
committersanine <sanine.not@pm.me>2022-08-28 11:25:44 -0500
commit0d6ece00397ebb9215ccf1af06cce22c3a94197e (patch)
tree022cc796822a998a59d8bf8896f02599ce6d3700 /src/CMakeLists.txt
parenta4dd0ad63c00f4dee3b86dfd3075d1d61b2b3180 (diff)
begin plibsys refactor
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt11
1 files changed, 10 insertions, 1 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 069d00a..cca9610 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -2,6 +2,15 @@ project(mossrose)
target_sources(mossrose PUBLIC
${CMAKE_CURRENT_LIST_DIR}/mossrose.c
- ${CMAKE_CURRENT_LIST_DIR}/mutex.c
${CMAKE_CURRENT_LIST_DIR}/channel.c
)
+
+
+if (MOSSROSE_BUILD_TESTS)
+ target_sources(test PUBLIC
+ ${CMAKE_CURRENT_LIST_DIR}/test/lily-test.c
+ ${CMAKE_CURRENT_LIST_DIR}/test/mossrose-test.c
+ ${CMAKE_CURRENT_LIST_DIR}/channel.test.c
+ ${CMAKE_CURRENT_LIST_DIR}/sound.test.c
+ )
+endif()