summaryrefslogtreecommitdiff
path: root/3rdparty/portaudio/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rdparty/portaudio/test/CMakeLists.txt')
-rw-r--r--3rdparty/portaudio/test/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/3rdparty/portaudio/test/CMakeLists.txt b/3rdparty/portaudio/test/CMakeLists.txt
new file mode 100644
index 0000000..973568f
--- /dev/null
+++ b/3rdparty/portaudio/test/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Test projects
+# Use the macro to add test projects
+
+MACRO(ADD_TEST appl_name)
+ ADD_EXECUTABLE(${appl_name} "${appl_name}.c")
+ TARGET_LINK_LIBRARIES(${appl_name} portaudio_static)
+ SET_TARGET_PROPERTIES(${appl_name}
+ PROPERTIES
+ FOLDER "Test"
+ )
+ENDMACRO(ADD_TEST)
+
+ADD_TEST(patest_longsine)