summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt29
1 files changed, 29 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 0000000..07d5174
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,29 @@
+cmake_minimum_required(VERSION 3.2)
+project(
+ mossrose
+ VERSION 0.1.0
+)
+
+
+option(MOSSROSE_BUILD_EXAMPLES "Build the example programs" OFF)
+
+
+add_subdirectory(${CMAKE_SOURCE_DIR}/portaudio EXCLUDE_FROM_ALL)
+
+add_library(mossrose
+ ${CMAKE_SOURCE_DIR}/src/mossrose.c
+)
+set_target_properties(mossrose PROPERTIES
+ C_STANDARD 99
+ CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic"
+ VERSION ${PROJECT_VERSION}
+ PUBLIC_HEADER src/mossrose.h
+)
+target_link_libraries(mossrose portaudio)
+
+
+if (MOSSROSE_BUILD_EXAMPLES)
+ include_directories(${CMAKE_SOURCE_DIR}/src)
+ add_custom_target(examples)
+ add_subdirectory(${CMAKE_SOURCE_DIR}/examples)
+endif()