summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 3 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d86dc60..b51a63f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -5,16 +5,14 @@ project(
)
+include_directories(${CMAKE_SOURCE_DIR}/include)
option(MOSSROSE_BUILD_EXAMPLES "Build the example programs" OFF)
add_subdirectory(${CMAKE_SOURCE_DIR}/portaudio EXCLUDE_FROM_ALL)
-add_library(mossrose
- ${CMAKE_SOURCE_DIR}/src/mossrose.c
- ${CMAKE_SOURCE_DIR}/src/mossrose-mutex.c
- ${CMAKE_SOURCE_DIR}/src/mossrose-channel.c
-)
+add_library(mossrose)
+add_subdirectory(${CMAKE_SOURCE_DIR}/src)
set_target_properties(mossrose PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic"
@@ -28,7 +26,6 @@ endif()
if (MOSSROSE_BUILD_EXAMPLES)
- include_directories(${CMAKE_SOURCE_DIR}/src)
add_custom_target(examples)
add_subdirectory(${CMAKE_SOURCE_DIR}/examples)
endif()