summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-03-04 10:47:15 -0600
committersanine <sanine.not@pm.me>2022-03-04 10:47:15 -0600
commit058f98a63658dc1a2579826ba167fd61bed1e21f (patch)
treebcba07a1615a14d943f3af3f815a42f3be86b2f3 /CMakeLists.txt
parent2f8028ac9e0812cb6f3cbb08f0f419e4e717bd22 (diff)
add assimp submodule
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4e9bf22..e06dd85 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -8,12 +8,14 @@ find_package(OpenGL REQUIRED)
find_package(Lua51 REQUIRED)
include_directories(${LUA_INCLUDE_DIR} ${CMAKE_SOURCE_DIR}/src)
+# link to third-party included libraries
+link_directories(${SRC_ROOT}/mesh/assimp-master/lib)
set(SRC_ROOT ${CMAKE_SOURCE_DIR}/src)
add_library(glad ${SRC_ROOT}/gl/glad/glad.c)
# add_library(stb_image src/stb_image/stb_image.c)
-
+add_subdirectory(${SRC_ROOT}/mesh/assimp-master)
set(HONEY_LIB_FILES
@@ -29,7 +31,7 @@ set(SOURCE_FILES
add_executable(honey ${SOURCE_FILES})
-set(LIBRARIES ${LUA_LIBRARIES} honeysuckle glad cairo m)
+set(LIBRARIES ${LUA_LIBRARIES} honeysuckle assimp glad cairo m)
if (WIN32)
set(LIBRARIES ${LIBRARIES} glfw3 opengl32)
else()