summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine-a <sanine.not@pm.me>2020-12-12 21:55:48 -0600
committersanine-a <sanine.not@pm.me>2020-12-12 21:55:48 -0600
commit09d34c697a488a8450161c62a601b04748098d96 (patch)
treeaa0a2d63b72ae24894225854a8607edd0ff2b18a /CMakeLists.txt
parentf64bdd048d6d8f338272326c437a86df2990b426 (diff)
add basic cairo bindings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt7
1 files changed, 5 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc5807a..1b11d68 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -15,6 +15,7 @@ add_library(stb_image src/stb_image/stb_image.c)
set(SOURCE_FILES
src/main.c
+ src/cairo_bindings.c
src/glm_bindings.c
src/glm_vec3_bindings.c
src/glm_vec4_bindings.c
@@ -29,10 +30,12 @@ set(SOURCE_FILES
src/window.c)
add_executable(honey ${SOURCE_FILES})
+
+set(LIBRARIES ${LUA_LIBRARIES} assimp glad cairo stb_image m)
if (WIN32)
- set(LIBRARIES ${LUA_LIBRARIES} assimp glfw3 opengl32 glad stb_image m)
+ set(LIBRARIES ${LIBRARIES} glfw3 opengl32)
else()
- set(LIBRARIES ${LUA_LIBRARIES} assimp glfw GL glad stb_image dl m)
+ set(LIBRARIES ${LIBRARIES} glfw GL dl)
endif()
target_link_libraries(honey ${LIBRARIES})