summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-22 21:37:12 -0500
committersanine <sanine.not@pm.me>2022-08-22 21:37:12 -0500
commit1f75a21851b0a0bd4bc766c458e67721dd37c9fd (patch)
tree498b9f43176f098c852099707e5eb1717bcd1ec1 /CMakeLists.txt
parent1f47b685f35455afcc7441389cdc60018f66d159 (diff)
add append_table()
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 9 insertions, 14 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b6c923..17bf14d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,10 +32,8 @@ add_subdirectory(${LIB_ROOT}/cglm)
add_subdirectory(${LIB_ROOT}/glfw-3.3.8)
-set(HONEY_SOURCE ${SRC_ROOT}/main.c ${SRC_ROOT}/logging/logging.c)
+set(HONEY_SOURCE ${SRC_ROOT}/main.c)
add_executable(honey ${HONEY_SOURCE})
-add_subdirectory(${SRC_ROOT}/gl)
-add_subdirectory(${SRC_ROOT}/image)
set(LIBRARIES lua5.1 honeysuckle assimp glfw)
if (WIN32)
@@ -51,18 +49,15 @@ target_link_libraries(honey ${LIBRARIES})
string(LENGTH "${CMAKE_SOURCE_DIR}/" SOURCE_PATH_SIZE)
add_definitions("-DSOURCE_PATH_SIZE=${SOURCE_PATH_SIZE}")
-set(TEST_SOURCES
- ${SRC_ROOT}/test/lily-test.c
- ${SRC_ROOT}/test/honey-test.c
-
- ${SRC_ROOT}/logging/logging.test.c
- ${SRC_ROOT}/gl/glad/glad.c
- ${SRC_ROOT}/gl/gl.test.c
- ${SRC_ROOT}/gl/window.test.c
-)
-
-add_executable(test EXCLUDE_FROM_ALL ${TEST_SOURCES})
+add_executable(test EXCLUDE_FROM_ALL)
set_target_properties(test PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
target_link_libraries(test lua5.1 honeysuckle glfw dl)
+
+
+add_subdirectory(${SRC_ROOT}/gl)
+add_subdirectory(${SRC_ROOT}/logging)
+add_subdirectory(${SRC_ROOT}/image)
+add_subdirectory(${SRC_ROOT}/util)
+add_subdirectory(${SRC_ROOT}/test)