summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine-a <sanine.not@pm.me>2020-10-18 12:10:48 -0500
committersanine-a <sanine.not@pm.me>2020-10-18 12:10:48 -0500
commit225167461d754b476b4fcc7726c492cc972ca654 (patch)
treed0a8060fe28a94b6fb24c002aa9744706e496b18 /CMakeLists.txt
parent1bc1f216e5682cd7918240f37f3709b642e08e2b (diff)
clear out old files, add basic scripting
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt10
1 files changed, 6 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 41cb559..0726040 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -4,16 +4,18 @@ project(honey_engine_demo)
#set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
find_package(OpenGL REQUIRED)
+find_package(Lua51 REQUIRED)
-add_executable(honey_engine_demo demo.c)
+include_directories(${LUA_INCLUDE_DIR})
set(CMAKE_C_FLAGS "-g")
-add_library(honey src/honey.c src/camera.c src/error.c src/input.c src/light.c src/mesh.c src/model.c src/primitives.c src/shader.c src/texture.c)
add_library(glad src/glad.c)
add_library(stb_image src/stb_image.c)
-set(LIBRARIES honey assimp glfw GL glad stb_image dl m)
-target_link_libraries(honey_engine_demo ${LIBRARIES})
+add_executable(honey src/main.c)
+
+set(LIBRARIES ${LUA_LIBRARIES} assimp glfw GL glad stb_image dl m)
+target_link_libraries(honey ${LIBRARIES})