summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-24 00:02:17 -0500
committersanine <sanine.not@pm.me>2022-08-24 00:02:17 -0500
commit2cb3c3df4099297b0a0554bb482e2de04fe86b5c (patch)
tree7796b4064c16460d9d603707b5256027649aa8b6 /CMakeLists.txt
parent709e1b6e1ce86f8da4fc136747fcefbc6c6057bd (diff)
add command-line arguments
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea8fca3..b428197 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,12 +32,13 @@ add_subdirectory(${LIB_ROOT}/lua-5.1.5)
add_subdirectory(${LIB_ROOT}/honeysuckle)
add_subdirectory(${LIB_ROOT}/cglm)
add_subdirectory(${LIB_ROOT}/glfw-3.3.8)
+add_subdirectory(${LIB_ROOT}/cargs)
set(HONEY_SOURCE ${SRC_ROOT}/main.c)
add_executable(honey ${HONEY_SOURCE})
-set(LIBRARIES lua5.1 honeysuckle glfw)
+set(LIBRARIES lua5.1 honeysuckle glfw cargs)
if (WIN32)
set(LIBRARIES ${LIBRARIES} opengl32)
else()
@@ -64,3 +65,4 @@ add_subdirectory(${SRC_ROOT}/image)
add_subdirectory(${SRC_ROOT}/util)
add_subdirectory(${SRC_ROOT}/test)
add_subdirectory(${SRC_ROOT}/glm)
+add_subdirectory(${SRC_ROOT}/options)