summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine-a <sanine.not@pm.me>2020-10-19 05:35:06 -0500
committersanine-a <sanine.not@pm.me>2020-10-19 05:35:06 -0500
commit41fa908dc15b522e53946a716f4f6c00520bd46f (patch)
treebc8176462000b2c77c00d3227037c1acbb13e0ee /CMakeLists.txt
parent2d046ffd16d8ff3a06f92ca438ca6b2d6842ce6a (diff)
add honey libraries back and reorganize directories
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt23
1 files changed, 18 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0726040..21f5467 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,7 +1,7 @@
cmake_minimum_required(VERSION 3.2)
project(honey_engine_demo)
-#set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
+set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
find_package(OpenGL REQUIRED)
find_package(Lua51 REQUIRED)
@@ -10,10 +10,23 @@ include_directories(${LUA_INCLUDE_DIR})
set(CMAKE_C_FLAGS "-g")
-add_library(glad src/glad.c)
-add_library(stb_image src/stb_image.c)
-
-add_executable(honey src/main.c)
+add_library(glad src/glad/glad.c)
+add_library(stb_image src/stb_image/stb_image.c)
+
+set(SOURCE_FILES
+ src/main.c
+ src/camera/camera.c
+ src/error/error.c
+ src/honey.c
+ src/input/input.c
+ src/light/light.c
+ src/mesh/mesh.c
+ src/model/model.c
+ src/primitives/primitives.c
+ src/shader/shader.c
+ src/texture/texture.c)
+
+add_executable(honey ${SOURCE_FILES})
set(LIBRARIES ${LUA_LIBRARIES} assimp glfw GL glad stb_image dl m)
target_link_libraries(honey ${LIBRARIES})