summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-21 21:54:47 -0500
committersanine <sanine.not@pm.me>2022-08-21 21:54:47 -0500
commit4ffe0ff4ac30361ea2a35dcfa07ca560ed865631 (patch)
treeec522e57b4e27f8c5388ef2175b0a77dd4537deb /CMakeLists.txt
parent74e48c197a57c9f7920ce048c9bf4b59d5303e18 (diff)
build with clang on visual studio
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt14
1 files changed, 8 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a76d76b..b5e8502 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,8 +1,10 @@
cmake_minimum_required(VERSION 3.2)
project(honey_engine_demo)
-set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
-set(CMAKE_C_FLAGS "-g")
+if (UNIX)
+ set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
+ set(CMAKE_C_FLAGS "-g")
+endif()
find_package(OpenGL REQUIRED)
@@ -10,7 +12,7 @@ set(SRC_ROOT ${CMAKE_SOURCE_DIR}/src)
set(LIB_ROOT ${CMAKE_SOURCE_DIR}/libs)
include_directories(
- ${LUA_INCLUDE_DIR}
+ ${LIB_ROOT}/lua-5.1.5/src
${CMAKE_SOURCE_DIR}/src
${LIB_ROOT}/honeysuckle/src
${LIB_ROOT}/glfw-3.3.8/include
@@ -44,11 +46,11 @@ set(SOURCE_FILES
add_executable(honey ${SOURCE_FILES})
-set(LIBRARIES lua5.1 honeysuckle assimp cairo m)
+set(LIBRARIES lua5.1 honeysuckle assimp glfw)
if (WIN32)
- set(LIBRARIES ${LIBRARIES} glfw3 opengl32)
+ set(LIBRARIES ${LIBRARIES} opengl32)
else()
- set(LIBRARIES ${LIBRARIES} glfw GL dl)
+ set(LIBRARIES ${LIBRARIES} GL dl m)
endif()
target_link_libraries(honey ${LIBRARIES})