summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine-a <sanine.not@pm.me>2020-11-29 16:26:12 -0600
committersanine-a <sanine.not@pm.me>2020-11-29 16:26:12 -0600
commit65f1870eaa68cd18f2136bd112c042728855af03 (patch)
treed76e307f867b8e7a8439ce1bb8f3bb30a63e3526 /CMakeLists.txt
parentf9f3ab244d12e6c7f38bf56dcf22c6a4913dc0f6 (diff)
refactor all files to use new argument parsing and table building functions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt16
1 files changed, 8 insertions, 8 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 0d96e64..336ff16 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -16,16 +16,16 @@ add_library(stb_image src/stb_image/stb_image.c)
set(SOURCE_FILES
src/main.c
src/glm_bindings.c
- src/camera/camera.c
+ src/camera.c
src/honey.c
- src/input/input.c
+ src/input.c
src/honey_lua.c
- src/light/light.c
- src/mesh/mesh.c
- src/primitives/primitives.c
- src/shader/shader.c
- src/texture/texture.c
- src/window/window.c)
+ src/light.c
+ src/mesh.c
+ src/primitives.c
+ src/shader.c
+ src/texture.c
+ src/window.c)
add_executable(honey ${SOURCE_FILES})
if (WIN32)