summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-09-13 12:29:37 -0500
committersanine <sanine.not@pm.me>2022-09-13 12:29:37 -0500
commit8abd7a81c988b26c19406c1ea669e050d56d2db5 (patch)
treee4c9eaa76370380bec3c507bd6f42b6200540022 /CMakeLists.txt
parent4826589445515d99e620da19e0d809728c071283 (diff)
add initial audio bindings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 7 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b428197..03e227b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -17,6 +17,7 @@ include_directories(
${LIB_ROOT}/honeysuckle/src
${LIB_ROOT}/glfw-3.3.8/include
${LIB_ROOT}/cglm/include
+ ${LIB_ROOT}/miniaudio
)
# disable byte-alignment in cglm
@@ -42,7 +43,7 @@ set(LIBRARIES lua5.1 honeysuckle glfw cargs)
if (WIN32)
set(LIBRARIES ${LIBRARIES} opengl32)
else()
- set(LIBRARIES ${LIBRARIES} GL dl m)
+ set(LIBRARIES ${LIBRARIES} GL dl pthread m)
endif()
target_link_libraries(honey ${LIBRARIES})
@@ -59,10 +60,11 @@ set_target_properties(test PROPERTIES
target_link_libraries(test lua5.1 honeysuckle glfw dl)
+add_subdirectory(${SRC_ROOT}/audio)
add_subdirectory(${SRC_ROOT}/gl)
-add_subdirectory(${SRC_ROOT}/logging)
-add_subdirectory(${SRC_ROOT}/image)
-add_subdirectory(${SRC_ROOT}/util)
-add_subdirectory(${SRC_ROOT}/test)
add_subdirectory(${SRC_ROOT}/glm)
+add_subdirectory(${SRC_ROOT}/image)
+add_subdirectory(${SRC_ROOT}/logging)
add_subdirectory(${SRC_ROOT}/options)
+add_subdirectory(${SRC_ROOT}/test)
+add_subdirectory(${SRC_ROOT}/util)