summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-20 15:37:04 -0500
committersanine <sanine.not@pm.me>2022-08-20 15:37:04 -0500
commit8b9b325b092b7157996cfbcdd7ce38f9e876fff8 (patch)
tree4c878f4a887d435d8c464112c2ad0cef1a6db2c8 /CMakeLists.txt
parentb6ccd8b31a78ef99f8c346d9b60f123c7ac813ec (diff)
fix bug in gl.bufferData and add error checking
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 2da7f20..c36fc99 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -62,10 +62,11 @@ set(TEST_SOURCES
${SRC_ROOT}/logging/logging.test.c
${SRC_ROOT}/gl/glad/glad.c
${SRC_ROOT}/gl/gl.test.c
+ ${SRC_ROOT}/gl/window.test.c
)
add_executable(test EXCLUDE_FROM_ALL ${TEST_SOURCES})
set_target_properties(test PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
-target_link_libraries(test lua5.1 honeysuckle dl)
+target_link_libraries(test lua5.1 honeysuckle glfw dl)