summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-22 12:39:51 -0500
committersanine <sanine.not@pm.me>2022-08-22 12:39:51 -0500
commitb2c0dd12d2a39e74f8e6d63bffec073ef0871ea7 (patch)
tree743d7981669e242898af107871c41f65ee7d75ac /CMakeLists.txt
parent249833947ff691dd79453c4d817387a6922236d6 (diff)
add uniforms
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 4 insertions, 17 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index dc9a83c..3796a43 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,5 @@
cmake_minimum_required(VERSION 3.2)
-project(honey_engine_demo)
+project(honey_engine)
if (UNIX)
set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
@@ -32,22 +32,9 @@ add_subdirectory(${LIB_ROOT}/cglm)
add_subdirectory(${LIB_ROOT}/glfw-3.3.8)
-set(HONEY_LIB_FILES
- ${SRC_ROOT}/logging/logging.c
- ${SRC_ROOT}/gl/glad/glad.c
- ${SRC_ROOT}/gl/gl.c
- ${SRC_ROOT}/gl/shader.c
- ${SRC_ROOT}/gl/drawing.c
- ${SRC_ROOT}/gl/data.c
- ${SRC_ROOT}/gl/window.c
-)
-
-set(SOURCE_FILES
- ${SRC_ROOT}/main.c
- ${HONEY_LIB_FILES}
- )
-
-add_executable(honey ${SOURCE_FILES})
+set(HONEY_SOURCE ${SRC_ROOT}/main.c ${SRC_ROOT}/logging/logging.c)
+add_executable(honey ${HONEY_SOURCE})
+add_subdirectory(${SRC_ROOT}/gl)
set(LIBRARIES lua5.1 honeysuckle assimp glfw)
if (WIN32)