summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-09-16 00:55:53 -0500
committersanine <sanine.not@pm.me>2022-09-16 00:55:53 -0500
commitd444d1c98fdefea6cf0aff50eb9b58d4dbcea6ed (patch)
treead4f0fea5d8f0d0b581978d50debccb63b3e6b38 /CMakeLists.txt
parentf2eb020c4199134e07632f3c6690d68381837b85 (diff)
begin assimp bindings
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 5 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 03e227b..e60f517 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -18,6 +18,9 @@ include_directories(
${LIB_ROOT}/glfw-3.3.8/include
${LIB_ROOT}/cglm/include
${LIB_ROOT}/miniaudio
+ ${LIB_ROOT}/assimp/include
+ # needed for assimp's config.h
+ ${CMAKE_BINARY_DIR}/libs/assimp/include
)
# disable byte-alignment in cglm
@@ -29,7 +32,7 @@ link_directories(${LIB_ROOT}/honeysuckle)
link_directories(${LIB_ROOT}/glfw-3.3.8/src)
add_subdirectory(${LIB_ROOT}/lua-5.1.5)
-#add_subdirectory(${LIB_ROOT}/assimp)
+add_subdirectory(${LIB_ROOT}/assimp)
add_subdirectory(${LIB_ROOT}/honeysuckle)
add_subdirectory(${LIB_ROOT}/cglm)
add_subdirectory(${LIB_ROOT}/glfw-3.3.8)
@@ -68,3 +71,4 @@ add_subdirectory(${SRC_ROOT}/logging)
add_subdirectory(${SRC_ROOT}/options)
add_subdirectory(${SRC_ROOT}/test)
add_subdirectory(${SRC_ROOT}/util)
+add_subdirectory(${SRC_ROOT}/import)