summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-04-16 11:55:09 -0500
committersanine <sanine.not@pm.me>2022-04-16 11:55:09 -0500
commitdb81b925d776103326128bf629cbdda576a223e7 (patch)
tree58bea8155c686733310009f6bed7363f91fbeb9d /CMakeLists.txt
parent55860037b14fb3893ba21cf2654c83d349cc1082 (diff)
move 3rd-party librarys into libs/ and add built-in honeysuckle
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 8 insertions, 4 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 507e2e2..ef38dec 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -7,15 +7,19 @@ set(CMAKE_C_FLAGS "-g")
find_package(OpenGL REQUIRED)
find_package(Lua51 REQUIRED)
+set(SRC_ROOT ${CMAKE_SOURCE_DIR}/src)
+set(LIB_ROOT ${CMAKE_SOURCE_DIR}/libs)
+
include_directories(${LUA_INCLUDE_DIR} ${CMAKE_SOURCE_DIR}/src)
-# link to third-party included libraries
-link_directories(${SRC_ROOT}/mesh/assimp-master/lib)
-set(SRC_ROOT ${CMAKE_SOURCE_DIR}/src)
+# link to third-party included libraries
+link_directories(${LIB_ROOT}/assimp/lib)
+link_directories(${LIB_ROOT}/honeysuckle)
add_library(glad ${SRC_ROOT}/gl/glad/glad.c)
# add_library(stb_image src/stb_image/stb_image.c)
-add_subdirectory(${SRC_ROOT}/mesh/assimp-master)
+add_subdirectory(${LIB_ROOT}/assimp)
+add_subdirectory(${LIB_ROOT}/honeysuckle)
set(HONEY_LIB_FILES