summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-19 00:39:04 -0500
committersanine <sanine.not@pm.me>2022-08-19 00:39:04 -0500
commitecde0c8110da1c1f94cce7f6a1fa9406d04eca69 (patch)
tree670e3d8706c652c1ffbf4f6406098af25a569c8b /CMakeLists.txt
parent275536b36657744d802866c060654e2b5cd5a5f8 (diff)
add several buffer-related functions
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 99964c3..2da7f20 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -29,6 +29,7 @@ add_subdirectory(${LIB_ROOT}/cglm)
set(HONEY_LIB_FILES
${SRC_ROOT}/logging/logging.c
+ ${SRC_ROOT}/gl/glad/glad.c
${SRC_ROOT}/gl/gl.c
${SRC_ROOT}/gl/window.c
)
@@ -59,6 +60,7 @@ set(TEST_SOURCES
${SRC_ROOT}/test/honey-test.c
${SRC_ROOT}/logging/logging.test.c
+ ${SRC_ROOT}/gl/glad/glad.c
${SRC_ROOT}/gl/gl.test.c
)
@@ -66,4 +68,4 @@ add_executable(test EXCLUDE_FROM_ALL ${TEST_SOURCES})
set_target_properties(test PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
-target_link_libraries(test lua5.1 honeysuckle)
+target_link_libraries(test lua5.1 honeysuckle dl)