summaryrefslogtreecommitdiff
path: root/libs/nanovg/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2023-02-12 23:53:22 -0600
committersanine <sanine.not@pm.me>2023-02-12 23:53:22 -0600
commitf1fe73d1909a2448a004a88362a1a532d0d4f7c3 (patch)
treeab37ae3837e2f858de2932bcee9f26e69fab3db1 /libs/nanovg/CMakeLists.txt
parentf567ea1e2798fd3156a416e61f083ea3e6b95719 (diff)
switch to tinyobj and nanovg from assimp and cairo
Diffstat (limited to 'libs/nanovg/CMakeLists.txt')
-rw-r--r--libs/nanovg/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/libs/nanovg/CMakeLists.txt b/libs/nanovg/CMakeLists.txt
new file mode 100644
index 0000000..8df0e4a
--- /dev/null
+++ b/libs/nanovg/CMakeLists.txt
@@ -0,0 +1,8 @@
+# added by me (sanine) for build compatibility
+# this is not a part of the original nanovg code
+
+cmake_minimum_required(VERSION 3.2)
+project(nanovg)
+
+add_library(nanovg STATIC src/nanovg.c)
+target_include_directories(nanovg PUBLIC src)