summaryrefslogtreecommitdiff
path: root/libs/ode-0.16.1/tests/UnitTest++/src/Makefile.am
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-10-01 20:59:36 -0500
committersanine <sanine.not@pm.me>2022-10-01 20:59:36 -0500
commitc5fc66ee58f2c60f2d226868bb1cf5b91badaf53 (patch)
tree277dd280daf10bf77013236b8edfa5f88708c7e0 /libs/ode-0.16.1/tests/UnitTest++/src/Makefile.am
parent1cf9cc3408af7008451f9133fb95af66a9697d15 (diff)
add ode
Diffstat (limited to 'libs/ode-0.16.1/tests/UnitTest++/src/Makefile.am')
-rw-r--r--libs/ode-0.16.1/tests/UnitTest++/src/Makefile.am33
1 files changed, 33 insertions, 0 deletions
diff --git a/libs/ode-0.16.1/tests/UnitTest++/src/Makefile.am b/libs/ode-0.16.1/tests/UnitTest++/src/Makefile.am
new file mode 100644
index 0000000..c17c4b1
--- /dev/null
+++ b/libs/ode-0.16.1/tests/UnitTest++/src/Makefile.am
@@ -0,0 +1,33 @@
+if WIN32
+SUBDIRS = Win32
+else
+SUBDIRS = Posix
+endif
+
+
+check_LTLIBRARIES = libunittestpp.la
+
+libunittestpp_la_SOURCES = AssertException.cpp AssertException.h \
+ CheckMacros.h Checks.cpp \
+ Checks.h Config.h \
+ DeferredTestReporter.cpp DeferredTestReporter.h \
+ DeferredTestResult.cpp DeferredTestResult.h \
+ MemoryOutStream.cpp MemoryOutStream.h \
+ ReportAssert.cpp ReportAssert.h \
+ Test.cpp TestDetails.cpp \
+ TestDetails.h Test.h \
+ TestList.cpp TestList.h \
+ TestMacros.h TestReporter.cpp \
+ TestReporter.h TestReporterStdout.cpp \
+ TestReporterStdout.h TestResults.cpp \
+ TestResults.h TestRunner.cpp \
+ TestRunner.h TestSuite.h \
+ TimeConstraint.cpp TimeConstraint.h \
+ TimeHelpers.h UnitTest++.h \
+ XmlTestReporter.cpp XmlTestReporter.h
+if WIN32
+libunittestpp_la_LIBADD = $(builddir)/Win32/libhelper.la
+else
+libunittestpp_la_LIBADD = $(builddir)/Posix/libhelper.la
+endif
+