summaryrefslogtreecommitdiff
path: root/src/mesh/assimp-master/doc/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-04-16 11:55:54 -0500
committersanine <sanine.not@pm.me>2022-04-16 11:55:54 -0500
commit8fb7916a0d0cb007a4c3a4e6a31af58765268ca3 (patch)
tree52b5524a94a5b04e17a1fd7f8aca988ab6d0c75f /src/mesh/assimp-master/doc/CMakeLists.txt
parentdb81b925d776103326128bf629cbdda576a223e7 (diff)
delete src/mesh/assimp-master
Diffstat (limited to 'src/mesh/assimp-master/doc/CMakeLists.txt')
-rw-r--r--src/mesh/assimp-master/doc/CMakeLists.txt42
1 files changed, 0 insertions, 42 deletions
diff --git a/src/mesh/assimp-master/doc/CMakeLists.txt b/src/mesh/assimp-master/doc/CMakeLists.txt
deleted file mode 100644
index b510d8c..0000000
--- a/src/mesh/assimp-master/doc/CMakeLists.txt
+++ /dev/null
@@ -1,42 +0,0 @@
-find_package( Doxygen REQUIRED )
-
-set( HTML_OUTPUT "AssimpDoc_Html" CACHE STRING "Output directory for generated HTML documentation. Defaults to AssimpDoc_Html." )
-
-# Enable Microsoft CHM help style only on Windows
-set( MICROSOFT_HELP_WORKSHOP "NO")
-if( MSVC )
- set( MICROSOFT_HELP_WORKSHOP "YES" )
-endif()
-
-configure_file(
- ${CMAKE_CURRENT_SOURCE_DIR}/Doxyfile.in
- ${CMAKE_CURRENT_BINARY_DIR}/Doxyfile
- @ONLY
-)
-
-add_custom_target(
- docs ALL
- DEPENDS docs.done
-)
-
-add_custom_command(
- OUTPUT docs.done
- COMMAND ${DOXYGEN_EXECUTABLE}
- COMMAND ${CMAKE_COMMAND} -E touch docs.done
- COMMENT "Generating assimp documentation"
- VERBATIM
- )
-
-if( DEFINED CMAKE_INSTALL_DOCDIR )
- install(
- DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/${HTML_OUTPUT}
- DESTINATION ${CMAKE_INSTALL_DOCDIR}
- )
- install(FILES
- ${CMAKE_CURRENT_SOURCE_DIR}/AssimpDoc_Html/AnimationOverview.png
- ${CMAKE_CURRENT_SOURCE_DIR}/AssimpDoc_Html/AnimationOverview.svg
- ${CMAKE_CURRENT_SOURCE_DIR}/AssimpDoc_Html/dragonsplash.png
- DESTINATION ${CMAKE_INSTALL_DOCDIR}/${HTML_OUTPUT}
- )
-endif()
-