summaryrefslogtreecommitdiff
path: root/src/mesh/assimp-master/port/AndroidJNI/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-03-04 10:47:15 -0600
committersanine <sanine.not@pm.me>2022-03-04 10:47:15 -0600
commit058f98a63658dc1a2579826ba167fd61bed1e21f (patch)
treebcba07a1615a14d943f3af3f815a42f3be86b2f3 /src/mesh/assimp-master/port/AndroidJNI/CMakeLists.txt
parent2f8028ac9e0812cb6f3cbb08f0f419e4e717bd22 (diff)
add assimp submodule
Diffstat (limited to 'src/mesh/assimp-master/port/AndroidJNI/CMakeLists.txt')
-rw-r--r--src/mesh/assimp-master/port/AndroidJNI/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/mesh/assimp-master/port/AndroidJNI/CMakeLists.txt b/src/mesh/assimp-master/port/AndroidJNI/CMakeLists.txt
new file mode 100644
index 0000000..8c821c7
--- /dev/null
+++ b/src/mesh/assimp-master/port/AndroidJNI/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.10)
+
+include_directories(./)
+include_directories(./../../)
+add_library( # Defines the name of the library.
+ android_jniiosystem
+
+ # Implements a static library.
+ STATIC
+
+ # relative path to source file(s).
+ AndroidJNIIOSystem.cpp
+ BundledAssetIOSystem.cpp
+)
+TARGET_LINK_LIBRARIES(android_jniiosystem android log)
+INSTALL(TARGETS android_jniiosystem EXPORT "${TARGETS_EXPORT_NAME}")