summaryrefslogtreecommitdiff
path: root/src/mesh/assimp-master/test/headercheck/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-04-16 11:55:54 -0500
committersanine <sanine.not@pm.me>2022-04-16 11:55:54 -0500
commit8fb7916a0d0cb007a4c3a4e6a31af58765268ca3 (patch)
tree52b5524a94a5b04e17a1fd7f8aca988ab6d0c75f /src/mesh/assimp-master/test/headercheck/CMakeLists.txt
parentdb81b925d776103326128bf629cbdda576a223e7 (diff)
delete src/mesh/assimp-master
Diffstat (limited to 'src/mesh/assimp-master/test/headercheck/CMakeLists.txt')
-rw-r--r--src/mesh/assimp-master/test/headercheck/CMakeLists.txt37
1 files changed, 0 insertions, 37 deletions
diff --git a/src/mesh/assimp-master/test/headercheck/CMakeLists.txt b/src/mesh/assimp-master/test/headercheck/CMakeLists.txt
deleted file mode 100644
index b77e023..0000000
--- a/src/mesh/assimp-master/test/headercheck/CMakeLists.txt
+++ /dev/null
@@ -1,37 +0,0 @@
-# This file is part of the Spring engine (GPL v2 or later), see LICENSE.html
-
-OPTION(ASSIMP_HEADERCHECK "adds the target headercheck which compiles every header file, default disabled because it adds many targets" OFF)
-if(ASSIMP_HEADERCHECK)
-include_directories(
- ${Assimp_SOURCE_DIR}/code/BoostWorkaround
-)
-
-FILE(GLOB_RECURSE headers
- ${Assimp_SOURCE_DIR}/code/*.h
-)
-
-set(headerchecklibs "")
-
-FOREACH( HEADER ${headers} )
-
- #pseudo unique name
- string(REPLACE "${Spring_SOURCE_DIR}" "" PLIST "${HEADER}")
- string(REPLACE "/" ";" PLIST "${PLIST}")
- SET(TEST_NAME "headercheck_")
-
- foreach(name ${PLIST})
- SET(TEST_NAME "${TEST_NAME}_${name}")
- endforeach()
-
- SET(TEST_FILE ${CMAKE_CURRENT_BINARY_DIR}/src-generated/${TEST_NAME}.cpp)
-
- # create test file
- configure_file( headercheck.cpp.in ${TEST_FILE} )
- # add library
- add_library( ${TEST_NAME} EXCLUDE_FROM_ALL ${TEST_FILE} )
- list(APPEND headerchecklibs ${TEST_NAME})
-ENDFOREACH()
-
-add_custom_target(headercheck DEPENDS ${headerchecklibs})
-
-endif()