summaryrefslogtreecommitdiff
path: root/src/nvg/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2023-02-19 19:03:51 -0600
committersanine <sanine.not@pm.me>2023-02-19 19:03:51 -0600
commitfb0eb6abac31ab1945a5b32e68824c9f9420d71f (patch)
treeb414bb9f93af85755df553d003ed88afc24cef50 /src/nvg/CMakeLists.txt
parentbc4af3b47260ee0f79343303b135d1ea32cde4d4 (diff)
refactor: bind (nearly) all nvg functions
Diffstat (limited to 'src/nvg/CMakeLists.txt')
-rw-r--r--src/nvg/CMakeLists.txt16
1 files changed, 15 insertions, 1 deletions
diff --git a/src/nvg/CMakeLists.txt b/src/nvg/CMakeLists.txt
index 8003158..9a96328 100644
--- a/src/nvg/CMakeLists.txt
+++ b/src/nvg/CMakeLists.txt
@@ -1,3 +1,17 @@
project(honey_engine)
-target_sources(honey PUBLIC ${CMAKE_CURRENT_LIST_DIR}/nvg.c)
+target_sources(honey PUBLIC
+ ${CMAKE_CURRENT_LIST_DIR}/color.c
+ ${CMAKE_CURRENT_LIST_DIR}/composite.c
+ ${CMAKE_CURRENT_LIST_DIR}/context.c
+ ${CMAKE_CURRENT_LIST_DIR}/frame.c
+ ${CMAKE_CURRENT_LIST_DIR}/image.c
+ ${CMAKE_CURRENT_LIST_DIR}/path.c
+ ${CMAKE_CURRENT_LIST_DIR}/render.c
+ ${CMAKE_CURRENT_LIST_DIR}/setup.c
+ ${CMAKE_CURRENT_LIST_DIR}/state.c
+ ${CMAKE_CURRENT_LIST_DIR}/transform.c
+ ${CMAKE_CURRENT_LIST_DIR}/text.c
+ ${CMAKE_CURRENT_LIST_DIR}/paint.c
+ ${CMAKE_CURRENT_LIST_DIR}/scissor.c
+)