summaryrefslogtreecommitdiff
path: root/src/opengl/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2023-03-10 02:05:18 -0600
committersanine <sanine.not@pm.me>2023-03-10 02:05:18 -0600
commit51c7235d4e0a2df109dd5050328a0ad4a1878ae4 (patch)
tree201b065e93bf6a35d2bab0e49bcd32f7a971da94 /src/opengl/CMakeLists.txt
parent5bb783912ac384156b8abbe6e83a5a61da73881d (diff)
refactor: move glfw functions into separate table
Diffstat (limited to 'src/opengl/CMakeLists.txt')
-rw-r--r--src/opengl/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/opengl/CMakeLists.txt b/src/opengl/CMakeLists.txt
new file mode 100644
index 0000000..4328596
--- /dev/null
+++ b/src/opengl/CMakeLists.txt
@@ -0,0 +1,21 @@
+project(honey_engine)
+
+set (GL ${CMAKE_CURRENT_LIST_DIR})
+
+target_sources(honey PUBLIC
+ ${GL}/data.c
+ ${GL}/drawing.c
+ ${GL}/shader.c
+ ${GL}/window.c
+ ${GL}/texture.c
+ ${GL}/gl.c
+)
+
+
+target_sources(test PUBLIC
+ ${GL}/gl.test.c
+ ${GL}/window.test.c
+)
+
+
+add_subdirectory(glad)