summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ea8fca3..b428197 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -32,12 +32,13 @@ add_subdirectory(${LIB_ROOT}/lua-5.1.5)
add_subdirectory(${LIB_ROOT}/honeysuckle)
add_subdirectory(${LIB_ROOT}/cglm)
add_subdirectory(${LIB_ROOT}/glfw-3.3.8)
+add_subdirectory(${LIB_ROOT}/cargs)
set(HONEY_SOURCE ${SRC_ROOT}/main.c)
add_executable(honey ${HONEY_SOURCE})
-set(LIBRARIES lua5.1 honeysuckle glfw)
+set(LIBRARIES lua5.1 honeysuckle glfw cargs)
if (WIN32)
set(LIBRARIES ${LIBRARIES} opengl32)
else()
@@ -64,3 +65,4 @@ add_subdirectory(${SRC_ROOT}/image)
add_subdirectory(${SRC_ROOT}/util)
add_subdirectory(${SRC_ROOT}/test)
add_subdirectory(${SRC_ROOT}/glm)
+add_subdirectory(${SRC_ROOT}/options)