summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt12
1 files changed, 2 insertions, 10 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d8ebc4b..bfba57b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,7 +19,6 @@ target_include_directories(
${LIB_ROOT}
${LIB_ROOT}/lua-5.1.5/src
${CMAKE_SOURCE_DIR}/src
- ${LIB_ROOT}/honeysuckle/src
${LIB_ROOT}/glfw-3.3.8/include
${LIB_ROOT}/cglm/include
${LIB_ROOT}/miniaudio
@@ -32,24 +31,17 @@ add_definitions(-DCGLM_ALL_UNALIGNED)
# link to third-party included libraries
target_link_directories(
honey PUBLIC
- ${LIB_ROOT}/honeysuckle
${LIB_ROOT}/glfw-3.3.8/src
)
add_subdirectory(${LIB_ROOT}/lua-5.1.5)
-add_subdirectory(${LIB_ROOT}/honeysuckle)
add_subdirectory(${LIB_ROOT}/cglm)
add_subdirectory(${LIB_ROOT}/glfw-3.3.8)
add_subdirectory(${LIB_ROOT}/cargs)
add_subdirectory(${LIB_ROOT}/ode-0.16.1)
add_subdirectory(${LIB_ROOT}/nanovg)
-target_include_directories(
- honeysuckle PUBLIC
- ${LIB_ROOT}/lua-5.1.5/src
-)
-
-set(LIBRARIES lua5.1 honeysuckle glfw cargs ODE nanovg OpenGL::GL)
+set(LIBRARIES lua5.1 glfw cargs ODE nanovg OpenGL::GL)
if (UNIX)
set(LIBRARIES ${LIBRARIES} dl pthread m)
endif()
@@ -65,7 +57,7 @@ add_executable(test EXCLUDE_FROM_ALL)
set_target_properties(test PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
-target_link_libraries(test lua5.1 honeysuckle glfw dl)
+target_link_libraries(test lua5.1 glfw dl)
add_subdirectory(${SRC_ROOT}/audio)