summaryrefslogtreecommitdiff
path: root/libs/assimp/port/AndroidJNI/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'libs/assimp/port/AndroidJNI/CMakeLists.txt')
-rw-r--r--libs/assimp/port/AndroidJNI/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/libs/assimp/port/AndroidJNI/CMakeLists.txt b/libs/assimp/port/AndroidJNI/CMakeLists.txt
new file mode 100644
index 0000000..8c821c7
--- /dev/null
+++ b/libs/assimp/port/AndroidJNI/CMakeLists.txt
@@ -0,0 +1,16 @@
+cmake_minimum_required(VERSION 3.10)
+
+include_directories(./)
+include_directories(./../../)
+add_library( # Defines the name of the library.
+ android_jniiosystem
+
+ # Implements a static library.
+ STATIC
+
+ # relative path to source file(s).
+ AndroidJNIIOSystem.cpp
+ BundledAssetIOSystem.cpp
+)
+TARGET_LINK_LIBRARIES(android_jniiosystem android log)
+INSTALL(TARGETS android_jniiosystem EXPORT "${TARGETS_EXPORT_NAME}")