summaryrefslogtreecommitdiff
path: root/src/glfw/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/glfw/CMakeLists.txt')
-rw-r--r--src/glfw/CMakeLists.txt11
1 files changed, 11 insertions, 0 deletions
diff --git a/src/glfw/CMakeLists.txt b/src/glfw/CMakeLists.txt
new file mode 100644
index 0000000..6637d2b
--- /dev/null
+++ b/src/glfw/CMakeLists.txt
@@ -0,0 +1,11 @@
+project(honey-engine)
+
+
+target_sources(honey PUBLIC
+ ${CMAKE_CURRENT_LIST_DIR}/setup.c
+ ${CMAKE_CURRENT_LIST_DIR}/context.c
+ ${CMAKE_CURRENT_LIST_DIR}/init.c
+ ${CMAKE_CURRENT_LIST_DIR}/input.c
+ ${CMAKE_CURRENT_LIST_DIR}/monitor.c
+ ${CMAKE_CURRENT_LIST_DIR}/window.c
+)