summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine-a <sanine.not@pm.me>2021-05-23 23:09:09 -0500
committersanine-a <sanine.not@pm.me>2021-05-23 23:09:09 -0500
commit98799b491512a235c43e183ac0a2ec762b75edfd (patch)
tree07b84dff29873bf572d314dc4665dfc46c1d8915 /CMakeLists.txt
parent30211fa4a3d65e7f26640d0c2caba3e5b48312b1 (diff)
set compiler flags per target and add hs_type_to_string tests
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 1 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 4dcfccd..2e02378 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -3,13 +3,12 @@ project(honeysuckle
VERSION 1.0.0
DESCRIPTION "A C library to make writing lua bindings simple")
-set(CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
-
find_package(Lua51 REQUIRED)
include_directories(${LUA_INCLUDE_DIR})
# build and link the library
add_library(honeysuckle src/honeysuckle.c)
+set_target_properties(honeysuckle PROPERTIES CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
target_link_libraries(honeysuckle ${LUA_LIBRARIES})
set_target_properties(honeysuckle PROPERTIES
VERSION ${PROJECT_VERSION}