summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt13
1 files changed, 12 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d9776cd..85f3024 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -66,8 +66,19 @@ set_target_properties(example_argument_parsing PROPERTIES
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
target_link_libraries(example_argument_parsing ${LUA_LIBRARIES} honeysuckle)
+add_executable(example_table_processing EXCLUDE_FROM_ALL
+ ${EX_ROOT}/table_processing/table_processing.c)
+set_target_properties(example_table_processing PROPERTIES
+ C_STANDARD 99
+ CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")
+target_link_libraries(example_table_processing ${LUA_LIBRARIES} honeysuckle)
+
+
add_custom_target(examples)
-add_dependencies(examples example_table_creation example_argument_parsing)
+add_dependencies(examples
+ example_table_creation
+ example_argument_parsing
+ example_table_processing)
include(GNUInstallDirs)