summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2021-12-25 23:12:46 -0600
committersanine <sanine.not@pm.me>2021-12-25 23:12:46 -0600
commit9c4bd59002109c850dda3ab79febc17f7f0367e9 (patch)
tree78444546c972a4317cc7da0e20bdecb9101f7587 /CMakeLists.txt
parent82009d685f48e95d58e0eaaf16f2bfc260e172ab (diff)
begin refactor to two-file library
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 3 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index baa2701..e209e55 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -2,7 +2,7 @@ cmake_minimum_required(VERSION 3.2)
project(
lily-test
VERSION 0.1.0
- DESCRIPTION "A super-simple single-header C test framework")
+ DESCRIPTION "A super-simple C test framework")
string(LENGTH "${CMAKE_SOURCE_DIR}/" SOURCE_PATH_SIZE)
add_definitions("-DSOURCE_PATH_SIZE=${SOURCE_PATH_SIZE}")
@@ -11,8 +11,9 @@ include_directories(${CMAKE_SOURCE_DIR})
set (TEST_SRC ${CMAKE_SOURCE_DIR}/tests)
add_executable(lily-metatest
${TEST_SRC}/main.c
+ ${TEST_SRC}/helpers.c
${TEST_SRC}/assertions.c
- ${TEST_SRC}/helpers.c)
+ )
set_target_properties(lily-metatest PROPERTIES
C_STANDARD 99
CMAKE_C_FLAGS "-Wall -Wextra -Werror -Wfatal-errors -Wpedantic")