summaryrefslogtreecommitdiff
path: root/3rdparty/libwav/tests/write_f32/CMakeLists.txt
diff options
context:
space:
mode:
authorstefonzo <stevester.robinson@gmail.com>2022-09-05 20:17:22 -0500
committerstefonzo <stevester.robinson@gmail.com>2022-09-05 20:17:22 -0500
commit7dac325122067bd8b453c0ec60fc1a768bb6f934 (patch)
treeaab7173f2c19eacaf433f443d2fc53e198ce89d7 /3rdparty/libwav/tests/write_f32/CMakeLists.txt
parent16431035f8e1c61e37adcceb8eab75e8d0dfed62 (diff)
adds libwav
Diffstat (limited to '3rdparty/libwav/tests/write_f32/CMakeLists.txt')
-rw-r--r--3rdparty/libwav/tests/write_f32/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/3rdparty/libwav/tests/write_f32/CMakeLists.txt b/3rdparty/libwav/tests/write_f32/CMakeLists.txt
new file mode 100644
index 0000000..cca1ecf
--- /dev/null
+++ b/3rdparty/libwav/tests/write_f32/CMakeLists.txt
@@ -0,0 +1,13 @@
+add_executable(write-f32 main.c)
+target_link_libraries(write-f32
+ wav::wav
+ $<$<PLATFORM_ID:Linux>:m>
+ )
+target_include_directories(write-f32 PRIVATE ${CMAKE_SOURCE_DIR}/include)
+target_compile_features(write-f32 PRIVATE ${wav_compile_features})
+target_compile_definitions(write-f32 PRIVATE ${wav_compile_definitions})
+target_compile_options(write-f32 PRIVATE
+ ${wav_c_flags}
+ $<$<CONFIG:RELEASE>:${wav_compile_options_release}>
+ $<$<CONFIG:RELWITHDEBINFO>:${wav_compile_options_release}>
+ )