summaryrefslogtreecommitdiff
path: root/3rdparty/portaudio/examples/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-27 23:52:56 -0500
committersanine <sanine.not@pm.me>2022-08-27 23:52:56 -0500
commita4dd0ad63c00f4dee3b86dfd3075d1d61b2b3180 (patch)
tree13bd5bfa15e6fea2a12f176bae79adf9c6fd0933 /3rdparty/portaudio/examples/CMakeLists.txt
parentbde3e4f1bb7b8f8abca0884a7d994ee1c17a66b1 (diff)
add plibsys
Diffstat (limited to '3rdparty/portaudio/examples/CMakeLists.txt')
-rw-r--r--3rdparty/portaudio/examples/CMakeLists.txt41
1 files changed, 41 insertions, 0 deletions
diff --git a/3rdparty/portaudio/examples/CMakeLists.txt b/3rdparty/portaudio/examples/CMakeLists.txt
new file mode 100644
index 0000000..f96b6ec
--- /dev/null
+++ b/3rdparty/portaudio/examples/CMakeLists.txt
@@ -0,0 +1,41 @@
+# Example projects
+
+MACRO(ADD_EXAMPLE appl_name)
+ ADD_EXECUTABLE(${appl_name} "${appl_name}.c")
+ TARGET_LINK_LIBRARIES(${appl_name} portaudio_static)
+ SET_TARGET_PROPERTIES(${appl_name} PROPERTIES FOLDER "Examples C")
+ IF(WIN32)
+ SET_PROPERTY(TARGET ${appl_name} APPEND_STRING PROPERTY COMPILE_DEFINITIONS _CRT_SECURE_NO_WARNINGS)
+ ENDIF()
+ENDMACRO(ADD_EXAMPLE)
+
+MACRO(ADD_EXAMPLE_CPP appl_name)
+ ADD_EXECUTABLE(${appl_name} "${appl_name}.cpp")
+ TARGET_LINK_LIBRARIES(${appl_name} portaudio_static)
+ SET_TARGET_PROPERTIES(${appl_name} PROPERTIES FOLDER "Examples C++")
+ IF(WIN32)
+ SET_PROPERTY(TARGET ${appl_name} APPEND_STRING PROPERTY COMPILE_DEFINITIONS _CRT_SECURE_NO_WARNINGS)
+ ENDIF()
+ENDMACRO(ADD_EXAMPLE_CPP)
+
+ADD_EXAMPLE(pa_devs)
+ADD_EXAMPLE(pa_fuzz)
+IF(PA_USE_ASIO AND WIN32)
+ ADD_EXAMPLE(paex_mono_asio_channel_select)
+ENDIF()
+ADD_EXAMPLE(paex_ocean_shore)
+TARGET_INCLUDE_DIRECTORIES(paex_ocean_shore PRIVATE ../src/common)
+ADD_EXAMPLE(paex_pink)
+ADD_EXAMPLE(paex_read_write_wire)
+ADD_EXAMPLE(paex_record)
+ADD_EXAMPLE(paex_record_file)
+TARGET_INCLUDE_DIRECTORIES(paex_record_file PRIVATE ../src/common)
+ADD_EXAMPLE(paex_saw)
+ADD_EXAMPLE(paex_sine)
+ADD_EXAMPLE_CPP(paex_sine_c++)
+IF(PA_USE_WMME AND WIN32)
+ ADD_EXAMPLE(paex_wmme_ac3)
+ ADD_EXAMPLE(paex_wmme_surround)
+ENDIF()
+ADD_EXAMPLE(paex_write_sine)
+ADD_EXAMPLE(paex_write_sine_nonint)