summaryrefslogtreecommitdiff
path: root/3rdparty/portaudio/test/CMakeLists.txt
diff options
context:
space:
mode:
authorsanine <sanine.not@pm.me>2022-08-27 23:52:56 -0500
committersanine <sanine.not@pm.me>2022-08-27 23:52:56 -0500
commita4dd0ad63c00f4dee3b86dfd3075d1d61b2b3180 (patch)
tree13bd5bfa15e6fea2a12f176bae79adf9c6fd0933 /3rdparty/portaudio/test/CMakeLists.txt
parentbde3e4f1bb7b8f8abca0884a7d994ee1c17a66b1 (diff)
add plibsys
Diffstat (limited to '3rdparty/portaudio/test/CMakeLists.txt')
-rw-r--r--3rdparty/portaudio/test/CMakeLists.txt13
1 files changed, 13 insertions, 0 deletions
diff --git a/3rdparty/portaudio/test/CMakeLists.txt b/3rdparty/portaudio/test/CMakeLists.txt
new file mode 100644
index 0000000..973568f
--- /dev/null
+++ b/3rdparty/portaudio/test/CMakeLists.txt
@@ -0,0 +1,13 @@
+# Test projects
+# Use the macro to add test projects
+
+MACRO(ADD_TEST appl_name)
+ ADD_EXECUTABLE(${appl_name} "${appl_name}.c")
+ TARGET_LINK_LIBRARIES(${appl_name} portaudio_static)
+ SET_TARGET_PROPERTIES(${appl_name}
+ PROPERTIES
+ FOLDER "Test"
+ )
+ENDMACRO(ADD_TEST)
+
+ADD_TEST(patest_longsine)